Discussion:
MongoDB 3.6.2 is released
(too old to reply)
'Kelsey Schubert' via mongodb-user
2018-01-10 22:55:15 UTC
Permalink
MongoDB 3.6.2 is out and is ready for production deployment. This release
contains only fixes since 3.6.1, and is a recommended upgrade for all 3.6
users.

Fixed in this release:

-

SERVER-31267 <https://jira.mongodb.org/browse/SERVER-31267>
CollectionCloner fails if collection is dropped between getMore calls
-

SERVER-31625 <https://jira.mongodb.org/browse/SERVER-31625> The
contents of {USER} needs to be escaped when querying for the groups using
LDAP server
-

SERVER-31684 <https://jira.mongodb.org/browse/SERVER-31684>
QueryPlanKilled (operation exceeded time limit) in $changeStream with
updateLookup
-

SERVER-31982 <https://jira.mongodb.org/browse/SERVER-31982> Shard does
not call config commit chunk migration command with majority writeConcern
nor checks for writeConcern errors.
-

SERVER-32246 <https://jira.mongodb.org/browse/SERVER-32246> PID file
permission on v3.6 make it not not monitorable using pid file
-

SERVER-32255 <https://jira.mongodb.org/browse/SERVER-32255> UUIDs may
be absent from shard secondary local collections
-

SERVER-32282 <https://jira.mongodb.org/browse/SERVER-32282> Aggregation
text search returns text score even if it wasn't requested when targeting
multiple shards in a sharded cluster
-

SERVER-32396 <https://jira.mongodb.org/browse/SERVER-32396> mongo shell
failed to connect with 3.6 connection string SRV
-

SERVER-32430 <https://jira.mongodb.org/browse/SERVER-32430>
DocumentSourceSort sorts array documents incorrectly if there is a
non-simple collation
-

SERVER-32529 <https://jira.mongodb.org/browse/SERVER-32529> Requiring
replSet for shards breaks Queryable Backup


3.6 Release Notes <http://docs.mongodb.org/manual/release-notes/3.6> | All
Issues
<https://jira.mongodb.org/issues/?jql=project%20in%20(SERVER%2CTOOLS%2CWT)%20AND%20resolution%3D%27Fixed%27%20and%20fixversion%3D%273.6.2%27>
| Downloads <http://www.mongodb.org/downloads>

For more information about MongoDB 3.6, read the What’s New in MongoDB 3.6
white paper​ <https://www.mongodb.com/collateral/mongodb-36-whats-new>

Get up to speed on MongoDB 3.6 with the MongoDB 3.6 Online Course
<https://university.mongodb.com/courses/M036/about>

As always, please let us know of any issues.

-- The MongoDB Team
--
You received this message because you are subscribed to the Google Groups "mongodb-user"
group.

For other MongoDB technical support options, see: https://docs.mongodb.com/manual/support/
---
You received this message because you are subscribed to the Google Groups "mongodb-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mongodb-user+***@googlegroups.com.
To post to this group, send email to mongodb-***@googlegroups.com.
Visit this group at https://groups.google.com/group/mongodb-user.
To view this discussion on the web visit https://groups.google.com/d/msgid/mongodb-user/CALYkeJEqno1uv%3DOt%3DCF-q%2B8cmy6cHJdX-UnopQjZDF%3DHidQPHQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Clive Strong
2018-01-12 13:21:05 UTC
Permalink
Nice. Updating production to 3.4.10 this weekend and will schedule QA to
be updated to 3.6.2 the following weekend! Happy days.
Post by 'Kelsey Schubert' via mongodb-user
MongoDB 3.6.2 is out and is ready for production deployment. This release
contains only fixes since 3.6.1, and is a recommended upgrade for all 3.6
users.
-
SERVER-31267 <https://jira.mongodb.org/browse/SERVER-31267>
CollectionCloner fails if collection is dropped between getMore calls
-
SERVER-31625 <https://jira.mongodb.org/browse/SERVER-31625> The
contents of {USER} needs to be escaped when querying for the groups using
LDAP server
-
SERVER-31684 <https://jira.mongodb.org/browse/SERVER-31684>
QueryPlanKilled (operation exceeded time limit) in $changeStream with
updateLookup
-
SERVER-31982 <https://jira.mongodb.org/browse/SERVER-31982> Shard
does not call config commit chunk migration command with majority
writeConcern nor checks for writeConcern errors.
-
SERVER-32246 <https://jira.mongodb.org/browse/SERVER-32246> PID file
permission on v3.6 make it not not monitorable using pid file
-
SERVER-32255 <https://jira.mongodb.org/browse/SERVER-32255> UUIDs may
be absent from shard secondary local collections
-
SERVER-32282 <https://jira.mongodb.org/browse/SERVER-32282>
Aggregation text search returns text score even if it wasn't requested
when targeting multiple shards in a sharded cluster
-
SERVER-32396 <https://jira.mongodb.org/browse/SERVER-32396> mongo
shell failed to connect with 3.6 connection string SRV
-
SERVER-32430 <https://jira.mongodb.org/browse/SERVER-32430>
DocumentSourceSort sorts array documents incorrectly if there is a
non-simple collation
-
SERVER-32529 <https://jira.mongodb.org/browse/SERVER-32529> Requiring
replSet for shards breaks Queryable Backup
3.6 Release Notes <http://docs.mongodb.org/manual/release-notes/3.6> | All
Issues
<https://jira.mongodb.org/issues/?jql=project%20in%20(SERVER%2CTOOLS%2CWT)%20AND%20resolution%3D%27Fixed%27%20and%20fixversion%3D%273.6.2%27>
| Downloads <http://www.mongodb.org/downloads>
For more information about MongoDB 3.6, read the What’s New in MongoDB
3.6 white paper​ <https://www.mongodb.com/collateral/mongodb-36-whats-new>
Get up to speed on MongoDB 3.6 with the MongoDB 3.6 Online Course
<https://university.mongodb.com/courses/M036/about>
As always, please let us know of any issues.
-- The MongoDB Team
--
You received this message because you are subscribed to the Google Groups "mongodb-user"
group.

For other MongoDB technical support options, see: https://docs.mongodb.com/manual/support/
---
You received this message because you are subscribed to the Google Groups "mongodb-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mongodb-user+***@googlegroups.com.
To post to this group, send email to mongodb-***@googlegroups.com.
Visit this group at https://groups.google.com/group/mongodb-user.
To view this discussion on the web visit https://groups.google.com/d/msgid/mongodb-user/b2f6e9e2-8413-4455-8c0b-c93d0605d752%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Carlos
2018-02-08 01:35:30 UTC
Permalink
My cluster is still on v 3.4... how do I upgrade it to v3.6?
Thanks!
Post by 'Kelsey Schubert' via mongodb-user
MongoDB 3.6.2 is out and is ready for production deployment. This release
contains only fixes since 3.6.1, and is a recommended upgrade for all 3.6
users.
-
SERVER-31267 <https://jira.mongodb.org/browse/SERVER-31267>
CollectionCloner fails if collection is dropped between getMore calls
-
SERVER-31625 <https://jira.mongodb.org/browse/SERVER-31625> The
contents of {USER} needs to be escaped when querying for the groups using
LDAP server
-
SERVER-31684 <https://jira.mongodb.org/browse/SERVER-31684>
QueryPlanKilled (operation exceeded time limit) in $changeStream with
updateLookup
-
SERVER-31982 <https://jira.mongodb.org/browse/SERVER-31982> Shard
does not call config commit chunk migration command with majority
writeConcern nor checks for writeConcern errors.
-
SERVER-32246 <https://jira.mongodb.org/browse/SERVER-32246> PID file
permission on v3.6 make it not not monitorable using pid file
-
SERVER-32255 <https://jira.mongodb.org/browse/SERVER-32255> UUIDs may
be absent from shard secondary local collections
-
SERVER-32282 <https://jira.mongodb.org/browse/SERVER-32282>
Aggregation text search returns text score even if it wasn't requested
when targeting multiple shards in a sharded cluster
-
SERVER-32396 <https://jira.mongodb.org/browse/SERVER-32396> mongo
shell failed to connect with 3.6 connection string SRV
-
SERVER-32430 <https://jira.mongodb.org/browse/SERVER-32430>
DocumentSourceSort sorts array documents incorrectly if there is a
non-simple collation
-
SERVER-32529 <https://jira.mongodb.org/browse/SERVER-32529> Requiring
replSet for shards breaks Queryable Backup
3.6 Release Notes <http://docs.mongodb.org/manual/release-notes/3.6> | All
Issues
<https://jira.mongodb.org/issues/?jql=project%20in%20(SERVER%2CTOOLS%2CWT)%20AND%20resolution%3D%27Fixed%27%20and%20fixversion%3D%273.6.2%27>
| Downloads <http://www.mongodb.org/downloads>
For more information about MongoDB 3.6, read the What’s New in MongoDB
3.6 white paper​ <https://www.mongodb.com/collateral/mongodb-36-whats-new>
Get up to speed on MongoDB 3.6 with the MongoDB 3.6 Online Course
<https://university.mongodb.com/courses/M036/about>
As always, please let us know of any issues.
-- The MongoDB Team
--
You received this message because you are subscribed to the Google Groups "mongodb-user"
group.

For other MongoDB technical support options, see: https://docs.mongodb.com/manual/support/
---
You received this message because you are subscribed to the Google Groups "mongodb-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mongodb-user+***@googlegroups.com.
To post to this group, send email to mongodb-***@googlegroups.com.
Visit this group at https://groups.google.com/group/mongodb-user.
To view this discussion on the web visit https://groups.google.com/d/msgid/mongodb-user/9dac310c-f12b-4870-a57f-095ccb85c26d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Manoj Gangwar
2018-02-08 18:31:28 UTC
Permalink
Carlos,
You can go through below steps ->
Compatibility Changes in MongoDB 3.6
https://docs.mongodb.com/manual/release-notes/3.6-compatibility/index.html

Java Driver Compatibility
https://docs.mongodb.com/ecosystem/drivers/driver-compatibility-reference/#java-driver-compatibility

Upgrade Config Servers to Replica Set
https://docs.mongodb.com/manual/tutorial/upgrade-config-servers-to-replica-set/

Upgrade a Sharded Cluster to 3.6
https://docs.mongodb.com/manual/release-notes/3.6-upgrade-sharded-cluster/

How to write the configuration is YAML format
https://docs.mongodb.com/manual/reference/configuration-options/


0) upgrade the binaries from 3.4.x to 3.6.2 on all boxes but do not restart
yet.
link ->
curl -O https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-3.6.2.tgz
tar -zxvf mongodb-linux-x86_64-3.6.2.tgz
mv mongodb-linux-x86_64-3.6.2 mongo-3.6.2
rm -rf *.tgz

1) Important -> Cluster should have enabled access controls and you have to
use the bindIp for this version.

a) security:
authorization: enabled
keyFile: <key file path>
b) net:
bindIp: 127.0.0.1,<that server's local IP>
port: <port of the process>

c) If you are using old formats for the configuration files then you have
to change the contents of the conf files to new 'yaml' format. The old way
of writing will not work.

d) all mongod, config, arbiters should be in wiredTiger before you proceed
to 3.6.2 IF you have to change any of them, do it first at this step.

e) all config servers must be converted from SCCC -> CSRS. Link is given

2) check on every mongod & config and update featureCompatibilityVersion to
3.4

db.adminCommand( { getParameter: 1, featureCompatibilityVersion: 1 } )
db.adminCommand( { setFeatureCompatibilityVersion: "3.4" } )

3) Take a backup of Config DB & prepare the scripts for restore as well, in
advance->

4) Stop the balancer from any mongos port

5) upgrade the binaries from 3.4.x to 3.6.2 on all boxes but do not restart
them, yet.
link to download ->
curl -O https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-3.6.2.tgz
tar -zxvf mongodb-linux-x86_64-3.6.2.tgz
mv mongodb-linux-x86_64-3.6.2 mongo-3.6.2
rm -rf *.tgz

6) Upgrade the config servers, one by one, secondaries & then primary.(242/
241/ 240)

first 2 secondaries, then connect 1st config(primary) and do the stepdown,

rs.status()
rs.stepDown()
Now, do the restart this last one, too.


7. upgrade the mongod shards, one by one, (1st shard-> secondary first &
then primary, and then complete the 2nd shard similar way)

8) Upgrade the arbiters instances if any, one by one.

9) Upgrade the mongos instances, one by one.

10) Enable backward-incompatible 3.6 features on all primaries and on mongos

db.adminCommand( { getParameter: 1, featureCompatibilityVersion: 1 } )

11) Re-enable the balancer using the mongos port.

sh.startBalancer()
sh.isBalancerRunning()
sh.getBalancerState()
exit

12) Now, modify Replica Set Protocol Version from pv0 to pv1 and restart
all mongod, one by one.
connect to all primaries with mongod port,


cfg = rs.conf();
cfg.protocolVersion=1;
rs.reconfig(cfg);

rs.conf();

13) check if all the processes are up in the cluster. And you are done.
--
You received this message because you are subscribed to the Google Groups "mongodb-user"
group.

For other MongoDB technical support options, see: https://docs.mongodb.com/manual/support/
---
You received this message because you are subscribed to the Google Groups "mongodb-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mongodb-user+***@googlegroups.com.
To post to this group, send email to mongodb-***@googlegroups.com.
Visit this group at https://groups.google.com/group/mongodb-user.
To view this discussion on the web visit https://groups.google.com/d/msgid/mongodb-user/fea3fece-4681-4b7f-81fc-d17ade62d8dd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Carlos
2018-02-08 23:41:53 UTC
Permalink
Thanks Manoj, that only applies to instances I fully own and have admin
privileges on, correct? My question was in the context of a cloud instance
managed by Mongo Atlas.
Post by Manoj Gangwar
Carlos,
You can go through below steps ->
Compatibility Changes in MongoDB 3.6
https://docs.mongodb.com/manual/release-notes/3.6-compatibility/index.html
Java Driver Compatibility
https://docs.mongodb.com/ecosystem/drivers/driver-compatibility-reference/#java-driver-compatibility
Upgrade Config Servers to Replica Set
https://docs.mongodb.com/manual/tutorial/upgrade-config-servers-to-replica-set/
Upgrade a Sharded Cluster to 3.6
https://docs.mongodb.com/manual/release-notes/3.6-upgrade-sharded-cluster/
How to write the configuration is YAML format
https://docs.mongodb.com/manual/reference/configuration-options/
0) upgrade the binaries from 3.4.x to 3.6.2 on all boxes but do not
restart yet.
link ->
curl -O https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-3.6.2.tgz
tar -zxvf mongodb-linux-x86_64-3.6.2.tgz
mv mongodb-linux-x86_64-3.6.2 mongo-3.6.2
rm -rf *.tgz
1) Important -> Cluster should have enabled access controls and you have
to use the bindIp for this version.
authorization: enabled
keyFile: <key file path>
bindIp: 127.0.0.1,<that server's local IP>
port: <port of the process>
c) If you are using old formats for the configuration files then you have
to change the contents of the conf files to new 'yaml' format. The old way
of writing will not work.
d) all mongod, config, arbiters should be in wiredTiger before you proceed
to 3.6.2 IF you have to change any of them, do it first at this step.
e) all config servers must be converted from SCCC -> CSRS. Link is given
2) check on every mongod & config and update featureCompatibilityVersion
to 3.4
db.adminCommand( { getParameter: 1, featureCompatibilityVersion: 1 } )
db.adminCommand( { setFeatureCompatibilityVersion: "3.4" } )
3) Take a backup of Config DB & prepare the scripts for restore as well,
in advance->
4) Stop the balancer from any mongos port
5) upgrade the binaries from 3.4.x to 3.6.2 on all boxes but do not
restart them, yet.
link to download ->
curl -O https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-3.6.2.tgz
tar -zxvf mongodb-linux-x86_64-3.6.2.tgz
mv mongodb-linux-x86_64-3.6.2 mongo-3.6.2
rm -rf *.tgz
6) Upgrade the config servers, one by one, secondaries & then
primary.(242/ 241/ 240)
first 2 secondaries, then connect 1st config(primary) and do the stepdown,
rs.status()
rs.stepDown()
Now, do the restart this last one, too.
7. upgrade the mongod shards, one by one, (1st shard-> secondary first &
then primary, and then complete the 2nd shard similar way)
8) Upgrade the arbiters instances if any, one by one.
9) Upgrade the mongos instances, one by one.
10) Enable backward-incompatible 3.6 features on all primaries and on mongos
db.adminCommand( { getParameter: 1, featureCompatibilityVersion: 1 } )
11) Re-enable the balancer using the mongos port.
sh.startBalancer()
sh.isBalancerRunning()
sh.getBalancerState()
exit
12) Now, modify Replica Set Protocol Version from pv0 to pv1 and restart
all mongod, one by one.
connect to all primaries with mongod port,
cfg = rs.conf();
cfg.protocolVersion=1;
rs.reconfig(cfg);
rs.conf();
13) check if all the processes are up in the cluster. And you are done.
--
You received this message because you are subscribed to the Google Groups "mongodb-user"
group.
https://docs.mongodb.com/manual/support/
---
You received this message because you are subscribed to a topic in the
Google Groups "mongodb-user" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/mongodb-user/zqcqn-WohzI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
Visit this group at https://groups.google.com/group/mongodb-user.
To view this discussion on the web visit
https://groups.google.com/d/msgid/mongodb-user/fea3fece-4681-4b7f-81fc-d17ade62d8dd%40googlegroups.com
<https://groups.google.com/d/msgid/mongodb-user/fea3fece-4681-4b7f-81fc-d17ade62d8dd%40googlegroups.com?utm_medium=email&utm_source=footer>
.
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "mongodb-user"
group.

For other MongoDB technical support options, see: https://docs.mongodb.com/manual/support/
---
You received this message because you are subscribed to the Google Groups "mongodb-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mongodb-user+***@googlegroups.com.
To post to this group, send email to mongodb-***@googlegroups.com.
Visit this group at https://groups.google.com/group/mongodb-user.
To view this discussion on the web visit https://groups.google.com/d/msgid/mongodb-user/CAKp7dmzR5zQAQiA85k_z8xSszET60cpyd2a_5A9YaDOQ%2BsEhFA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Manoj Gangwar
2018-02-09 00:35:15 UTC
Permalink
Yes, true. I have stated the steps for a Manual Upgrade process for a
Sharded cluster (not Atlas!)

I see this link
: https://docs.atlas.mongodb.com/scale-cluster/#scale-cluster-version
Post by 'Kelsey Schubert' via mongodb-user
MongoDB 3.6.2 is out and is ready for production deployment. This release
contains only fixes since 3.6.1, and is a recommended upgrade for all 3.6
users.
-
SERVER-31267 <https://jira.mongodb.org/browse/SERVER-31267>
CollectionCloner fails if collection is dropped between getMore calls
-
SERVER-31625 <https://jira.mongodb.org/browse/SERVER-31625> The
contents of {USER} needs to be escaped when querying for the groups using
LDAP server
-
SERVER-31684 <https://jira.mongodb.org/browse/SERVER-31684>
QueryPlanKilled (operation exceeded time limit) in $changeStream with
updateLookup
-
SERVER-31982 <https://jira.mongodb.org/browse/SERVER-31982> Shard
does not call config commit chunk migration command with majority
writeConcern nor checks for writeConcern errors.
-
SERVER-32246 <https://jira.mongodb.org/browse/SERVER-32246> PID file
permission on v3.6 make it not not monitorable using pid file
-
SERVER-32255 <https://jira.mongodb.org/browse/SERVER-32255> UUIDs may
be absent from shard secondary local collections
-
SERVER-32282 <https://jira.mongodb.org/browse/SERVER-32282>
Aggregation text search returns text score even if it wasn't requested
when targeting multiple shards in a sharded cluster
-
SERVER-32396 <https://jira.mongodb.org/browse/SERVER-32396> mongo
shell failed to connect with 3.6 connection string SRV
-
SERVER-32430 <https://jira.mongodb.org/browse/SERVER-32430>
DocumentSourceSort sorts array documents incorrectly if there is a
non-simple collation
-
SERVER-32529 <https://jira.mongodb.org/browse/SERVER-32529> Requiring
replSet for shards breaks Queryable Backup
3.6 Release Notes <http://docs.mongodb.org/manual/release-notes/3.6> | All
Issues
<https://jira.mongodb.org/issues/?jql=project%20in%20(SERVER%2CTOOLS%2CWT)%20AND%20resolution%3D%27Fixed%27%20and%20fixversion%3D%273.6.2%27>
| Downloads <http://www.mongodb.org/downloads>
For more information about MongoDB 3.6, read the What’s New in MongoDB
3.6 white paper​ <https://www.mongodb.com/collateral/mongodb-36-whats-new>
Get up to speed on MongoDB 3.6 with the MongoDB 3.6 Online Course
<https://university.mongodb.com/courses/M036/about>
As always, please let us know of any issues.
-- The MongoDB Team
--
You received this message because you are subscribed to the Google Groups "mongodb-user"
group.

For other MongoDB technical support options, see: https://docs.mongodb.com/manual/support/
---
You received this message because you are subscribed to the Google Groups "mongodb-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mongodb-user+***@googlegroups.com.
To post to this group, send email to mongodb-***@googlegroups.com.
Visit this group at https://groups.google.com/group/mongodb-user.
To view this discussion on the web visit https://groups.google.com/d/msgid/mongodb-user/7e58fe26-d694-4898-9808-829f3919b82b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Continue reading on narkive:
Loading...